Discussion:
Libre-Office calcul moyen
(trop ancien pour répondre)
dyrmak
2020-05-29 14:40:22 UTC
Permalink
Bonjour Bonsoir,

Dans un document LibreOffice calc j'ai affichage douteux de cellule:


La formule A+B+C+D appliquée à une cellule
l'initialise à zéro.

La formule A+B+C+D qui s'affiche dans la barre est
Fx Σ =SOMME(B15;D15;F15;G15)


Mais la formule E+H+(F+G)/2 appliquée à une autre
cellule ne l'initialise pas à zéro mais
y affiche un inquiétant #DIV 0!

Si on prend soin d'initialiser E=F=G=H=0 la cellule
s'affiche correctement à zéro


La formule E+H+(F+G)/2 qui s'affiche dans la barre est
Fx Σ =SOMME(D11;G11;MOYENNE(F9;F11))

Il me semble qu'il faut bien examiner les formules et bien
ouvrir l'œil ?

dyrmak
--
El barquito de río seco
++++ --- ++++
Linux operating system
++++ --- ++++
Jean-Baptiste Faure
2020-05-29 15:09:04 UTC
Permalink
Bonjour,

Le 29/05/2020 à 16:40, dyrmak a écrit :
[...]
Post by dyrmak
Mais la formule E+H+(F+G)/2 appliquée à une autre
cellule ne l'initialise pas à zéro mais
y affiche un inquiétant #DIV 0!
Si on prend soin d'initialiser E=F=G=H=0 la cellule
s'affiche correctement à zéro
La formule E+H+(F+G)/2 qui s'affiche dans la barre est
Fx Σ =SOMME(D11;G11;MOYENNE(F9;F11))
Il me semble qu'il faut bien examiner les formules et bien
ouvrir l'œil ?
La fonction MOYENNE() divise la somme par le nombre de cellules non vides.
Dans une feuille vide, mettre dans A1 =MOYENNE(E1;E2)
on obtient #DIV 0!
Mettre la valeur 1 dans E1, on obtient 1 en A1.
Mettre 0 dans E2, on obtient 0,5 en A1.

C'est pratique pour calculer une moyenne sans connaitre le nombre de
valeurs : =MOYENNE(B:B) calcule la moyenne de la colonne B.

JBF

Loading...